Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: Pics of my install

  1. #1
    Sotally Tober
    Well I finally had some time to upload some pics.
    Damn wire and fuses aint cheap
    http://www.***boat.com/image_center/...84IMG_7143.JPG
    I mounted my amps in the single berth. Luckily the panel had about 2" of space behind it to hide all the wires,
    http://www.***boat.com/image_center/...84IMG_7147.JPG
    Finished with amps
    http://www.***boat.com/image_center/...84IMG_7228.JPG
    I pulled 175' of new twiste 12G speaker wire. All MB quart componets had thier crossover mounted with SS screws. What a bitch in a boat.
    Front speakers in the open bow.
    http://www.***boat.com/image_center/...84IMG_7146.JPG
    At the helm
    http://www.***boat.com/image_center/...84IMG_7145.JPG
    The rear ones I did the Pce-216 in coaxial as I was dealing with the vinyl. Every 6.5 that I replaced I had to make the hole bigger. I wanted the speaker as flush as it could go. I did not want the spacer ring holding the grill out. A lot of work. but I'm happy.
    http://www.***boat.com/image_center/...84IMG_7141.JPG

  2. #2
    Sotally Tober
    The subs I put in my wet bar. There was one 10' from the factory facing forward behind the drivers seat. The other one I aimed back. I had to build wedge boxes so my ice chest would fit between the boxes, as the spots where the subs were located are at an angle.
    The one that was replaced.
    http://www.***boat.com/image_center/...84IMG_7106.JPG
    The second one, I had to work around a light hole. It still fit in the right spot.
    http://www.***boat.com/image_center/...84IMG_7103.JPG
    Sure is scary cutting holes in a new boat! There is one of the boxes in the background before carpet.
    http://www.***boat.com/image_center/...84IMG_7105.JPG
    Mounted and need to get sub grills.
    http://www.***boat.com/image_center/...84IMG_7142.JPG
    The ice chest that fits under the wet bar/ice chest.
    http://www.***boat.com/image_center/...84IMG_7144.JPG

  3. #3
    JB in so cal
    Very nice work. Where were you when I needed stuff put in my truck?

  4. #4
    Sotally Tober
    Very nice work. Where were you when I needed stuff put in my truck?
    Thanks JB. I had my truck done by the so called "pro's" I would never try it in a new auto/truck. I do not know how to take door panels apart. I would break some plastic part and the thing would rattle down the road. Now a boat I can work on. I think, I'm sure someone could have done it better.

  5. #5
    Sotally Tober
    I thank you all for the help as I did this project. I do have one problem. I get a poping noise anytime I use my trim tabs or the trim for the outdrive. My RCA's go under the helm to my infinity amp (pass through) in the helm. Then tied to the speaker wires that head up. They are totally away from the 1/0 G power wires. Any ideas?
    I think it sounds very good. IMO and that what matters. I know some of you think kicker is crap so let the flaming begin.

  6. #6
    Sotally Tober
    Unplug the RCAs and tell me if it goes away.
    I already did that it DOES go away. So I know it is getting it from them. If the rca are tied to wires that parallel back to the engine would it pick it up from the secondary wires? The rca's are about 2' from any of the helm wires. But they are tied to some wires that eventually are part of the engine/helm wires.
    Thanks for all your help John.

  7. #7
    WFS ADAM
    I thank you all for the help as I did this project. I do have one problem. I get a poping noise anytime I use my trim tabs or the trim for the outdrive. My RCA's go under the helm to my infinity amp (pass through) in the helm. Then tied to the speaker wires that head up. They are totally away from the 1/0 G power wires. Any ideas?
    I think it sounds very good. IMO and that what matters. I know some of you think kicker is crap so let the flaming begin.
    THAT IS A common problem you have 2 put diodes at the pump switch so it wont backfeed .. call me and ill tell u how 951 696 2200 adam :idea:

  8. #8
    Sotally Tober
    Which would be easier? A relay I would assume be mounted right at the elec. pump. I would then have to run new power to each relay and use the switch to power the relay. Would this not create the feed back. It really pops when you let off the switch. I worry about blowing a tweet.
    If it is common that atleast makes me feel a little better. I tried moving the rca's around with no luck.

  9. #9
    Cole Sanger
    Thanks, Now I am going to have to go wire up my boat with new stuff and post pictures just so I can try and compete. First with the trailer, and now with the boat stereo. Looking Good. Keep up the good work. :rollside:

  10. #10
    Essex29
    http://www.***boat.com/image_center/...84IMG_7142.JPG
    Did you make them bigger so that the ring is set inside the hole ? with a router?
    looks great

Page 1 of 3 123 LastLast

Similar Threads

  1. Giltronix Install Pics
    By BLOWN HOWARD in forum Audio
    Replies: 10
    Last Post: 12-08-2017, 09:03 PM
  2. Stereo Install in our 27 Ultra Teaser Pics
    By sigepmock in forum Sandbar
    Replies: 43
    Last Post: 09-08-2006, 08:19 PM
  3. Some pics of my install.....
    By kcvega in forum Audio
    Replies: 8
    Last Post: 06-07-2006, 08:52 AM
  4. How to install
    By AngryJosh in forum Audio
    Replies: 6
    Last Post: 02-15-2006, 01:37 PM
  5. Some new pics after install of DNE engine
    By diggler in forum Jet Boats
    Replies: 14
    Last Post: 05-09-2005, 04:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •